[NOI2011]阿狸的打字机

题目描述

打字机上只有28个按键,分别印有26个小写英文字母和’B’、’P’两个字母。经阿狸研究发现,这个打字机是这样工作的:

·输入小写字母,打字机的一个凹槽中会加入这个字母(这个字母加在凹槽的最后)。

·按一下印有’B’的按键,打字机凹槽中最后一个字母会消失。

·按一下印有’P’的按键,打字机会在纸上打印出凹槽中现有的所有字母并换行,但凹槽中的字母不会消失。

例如,阿狸输入aPaPBbP,纸上被打印的字符如下:

a aa ab 我们把纸上打印出来的字符串从1开始顺序编号,一直到n。打字机有一个非常有趣的功能,在打字机中暗藏一个带数字的小键盘,在小键盘上输入两个数(x,y)(其中1≤x,y≤n),打字机会显示第x个打印的字符串在第y个打印的字符串中出现了多少次。

阿狸发现了这个功能以后很兴奋,他想写个程序完成同样的功能,你能帮助他么?

输入输出格式

输入格式:
输入的第一行包含一个字符串,按阿狸的输入顺序给出所有阿狸输入的字符。

第二行包含一个整数m,表示询问个数。

接下来m行描述所有由小键盘输入的询问。其中第i行包含两个整数x, y,表示第i个询问为(x, y)。
输出格式:
输出m行,其中第i行包含一个整数,表示第i个询问的答案。

输入输出样例

输入样例:
aPaPBbP
3
1 2
1 3
2 3
输出样例:
2
1
0

说明

数据范围:

对于100%的数据,n<=100000,m<=100000,第一行总长度<=100000。

分析

AC自动机已经手生到错了一片。。。

先将输出串存在trie上,在trie上构建AC自动机
可以看出要求出对于root-x的点上有多少个节点能通过跳fail指针跳到y串的结束节点
所以将fail指针反向建树(fail树)
因为如果x节点能跳到y节点,x节点一定是y节点fail树上的子树,这个就用dfn序列判断
将每组询问存在相应节点上
再次dfs,将root-x的dfn状况储存在树状数组+判断与x相关的询问就行


CODE

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;
int n,m,num,sum,doe,top;
char s[202020];
int id[202020];
int ch[202020][26],fa[202020],f[202020];
int pre[202020],now[202020],son[202020];
int sz[202020],dfn[202020];
int ans[202020];
struct node
{
int id,x;
};
vector<node> ask[202020];
void add(int x,int y)
{
++doe;
pre[doe]=now[x];
now[x]=doe;
son[doe]=y;
}
void build_trie()
{
int nw=0;
for (int i=1;i<=n;++i)
{
if (s[i]=='B')
{
nw=fa[nw];
continue;
}
if (s[i]=='P')
{
++sum;
id[sum]=nw;
continue;
}
int chh=s[i]-'a';
if (!ch[nw][chh])
{
++num;
ch[nw][chh]=num;
fa[num]=nw;
}
nw=ch[nw][chh];
}
}
queue<int> que;
void build_AC()
{
for (int i=0;i<26;++i)
if (ch[0][i])
{
que.push(ch[0][i]);
f[ch[0][i]]=0;
add(0,ch[0][i]);
}
while (!que.empty())
{
int x=que.front();
que.pop();
for (int i=0;i<26;++i)
if (ch[x][i])
{
int kkk=f[x],y=ch[x][i];
while (kkk && !ch[kkk][i]) kkk=f[kkk];
f[y]=ch[kkk][i];
add(f[y],y);
que.push(y);
}
}
}
void dfs(int x)
{
++top;
dfn[x]=top;
sz[x]=1;
int p=now[x];
while (p)
{
int y=son[p];
dfs(y);
sz[x]+=sz[y];
p=pre[p];
}
}
int sss[202020];
void add_s(int x,int v)
{
while (x<=top)
{
sss[x]+=v;
x+=(x&(-x));
}
}
int find(int x)
{
int S=0;
while (x>0)
{
S+=sss[x];
x-=(x&(-x));
}
return S;
}
void dfs2(int x)
{
add_s(dfn[x],1);
if (!ask[x].empty())
{
int len=ask[x].size();
for (int j=0;j<len;++j)
{
int y=ask[x][j].x;
int S=find(dfn[y]+sz[y]-1)-find(dfn[y]-1);
ans[ask[x][j].id]=S;
}
}
for (int i=0;i<26;++i)
if (ch[x][i])
dfs2(ch[x][i]);
add_s(dfn[x],-1);
}
int main()
{
// freopen("a.in","r",stdin);
// freopen("a.out","w",stdout);
scanf("%s",s+1);
n=strlen(s+1);
build_trie();
build_AC();
dfs(0);
scanf("%d",&m);
int x,y;
for (int i=1;i<=m;++i)
{
scanf("%d%d",&y,&x);
node dd;;
dd.id=i;
dd.x=id[y];
ask[id[x]].push_back(dd);
}
dfs2(0);
for (int i=1;i<=m;++i)
printf("%d\n",ans[i]);
return 0;
}
--------------------------